#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "= *(.*)"
Local $sString = "Cliente = CON CLIENTE ABCD " & @CRLF & _
"Regra = Alocação em compromissadas Limite - Min. R$ 0 - ( 0,00% ) - Max. R$ 0 - ( 0,00% ) Valor Base - R$ 0,00 Valor Apurado Financeiro - R$0,00 - ( 0,00% )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")