// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"= *(.*)").unwrap();
let string = "Cliente = CON CLIENTE ABCD
Regra = Alocação em compromissadas Limite - Min. R$ 0 - ( 0,00% ) - Max. R$ 0 - ( 0,00% ) Valor Base - R$ 0,00 Valor Apurado Financeiro - R$0,00 - ( 0,00% )";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}