$re = '/= *(.*)/';
$str = 'Cliente = CON CLIENTE ABCD
Regra = Alocação em compromissadas Limite - Min. R$ 0 - ( 0,00% ) - Max. R$ 0 - ( 0,00% ) Valor Base - R$ 0,00 Valor Apurado Financeiro - R$0,00 - ( 0,00% )';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);