import Foundation
let pattern = #"= *(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Cliente = CON CLIENTE ABCD
Regra = Alocação em compromissadas Limite - Min. R$ 0 - ( 0,00% ) - Max. R$ 0 - ( 0,00% ) Valor Base - R$ 0,00 Valor Apurado Financeiro - R$0,00 - ( 0,00% )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}