#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bHRB\b(?:[-\s]N(?:umme)?r)?[,.:\s]*(\d+)"
Local $sString = "######## Most cases are likes this: ###############" & @CRLF & _
"" & @CRLF & _
"HRB 21156" & @CRLF & _
"HRB, 1234" & @CRLF & _
"HRB: 99887" & @CRLF & _
"" & @CRLF & _
"######## Some cases can be likes this: ###############" & @CRLF & _
"######## How to I catch the numbers as shown above? ##########" & @CRLF & _
"HRB-Nummer 21156" & @CRLF & _
"HRB-Nr. 12345" & @CRLF & _
"HRB-Nr: 21156" & @CRLF & _
"HRB Nr. 21156" & @CRLF & _
"HRB Nr: 21156" & @CRLF & _
"HRB Nr.: 21156" & @CRLF & _
"HRB Nummer 21156" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")