re = /\bHRB\b(?:[-\s]N(?:umme)?r)?[,.:\s]*(\d+)/m
str = '######## Most cases are likes this: ###############
HRB 21156
HRB, 1234
HRB: 99887
######## Some cases can be likes this: ###############
######## How to I catch the numbers as shown above? ##########
HRB-Nummer 21156
HRB-Nr. 12345
HRB-Nr: 21156
HRB Nr. 21156
HRB Nr: 21156
HRB Nr.: 21156
HRB Nummer 21156
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end