const regex = new RegExp('\\bHRB\\b(?:[-\\s]N(?:umme)?r)?[,.:\\s]*(\\d+)', 'gm')
const str = `######## Most cases are likes this: ###############
HRB 21156
HRB, 1234
HRB: 99887
######## Some cases can be likes this: ###############
######## How to I catch the numbers as shown above? ##########
HRB-Nummer 21156
HRB-Nr. 12345
HRB-Nr: 21156
HRB Nr. 21156
HRB Nr: 21156
HRB Nr.: 21156
HRB Nummer 21156
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}