import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bHRB\\b(?:[-\\s]N(?:umme)?r)?[,.:\\s]*(\\d+)";
final String string = "######## Most cases are likes this: ###############\n\n"
+ "HRB 21156\n"
+ "HRB, 1234\n"
+ "HRB: 99887\n\n"
+ "######## Some cases can be likes this: ###############\n"
+ "######## How to I catch the numbers as shown above? ##########\n"
+ "HRB-Nummer 21156\n"
+ "HRB-Nr. 12345\n"
+ "HRB-Nr: 21156\n"
+ "HRB Nr. 21156\n"
+ "HRB Nr: 21156\n"
+ "HRB Nr.: 21156\n"
+ "HRB Nummer 21156\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}