package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bHRB\b(?:[-\s]N(?:umme)?r)?[,.:\s]*(\d+)`)
var str = `######## Most cases are likes this: ###############
HRB 21156
HRB, 1234
HRB: 99887
######## Some cases can be likes this: ###############
######## How to I catch the numbers as shown above? ##########
HRB-Nummer 21156
HRB-Nr. 12345
HRB-Nr: 21156
HRB Nr. 21156
HRB Nr: 21156
HRB Nr.: 21156
HRB Nummer 21156
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}