using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-zА-Яа-я\s]{2,}[-‐‑-ꟷー一]?[A-Za-zА-Яа-я\s]+$";
string input = @"Анна-Мария Кузяпкина
Ян Пупкин
Петр Фёдоров
Сергей Михайлович Прокудин-Горский
Василий Иванов
Д'Артаньян
Michael Jackson
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}