import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-zА-Яа-я\\s]{2,}[-‐‑-ꟷー一]?[A-Za-zА-Яа-я\\s]+$";
final String string = "Анна-Мария Кузяпкина\n"
+ "Ян Пупкин\n"
+ "Петр Фёдоров\n"
+ "Сергей Михайлович Прокудин-Горский\n"
+ "Василий Иванов\n"
+ "Д'Артаньян\n"
+ "Michael Jackson\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}