import re
regex = re.compile(r"^[A-Za-zА-Яа-я\s]{2,}[-‐‑-ꟷー一]?[A-Za-zА-Яа-я\s]+$", flags=re.MULTILINE)
test_str = ("Анна-Мария Кузяпкина\n"
"Ян Пупкин\n"
"Петр Фёдоров\n"
"Сергей Михайлович Прокудин-Горский\n"
"Василий Иванов\n"
"Д'Артаньян\n"
"Michael Jackson\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")