// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-zА-Яа-я\s]{2,}[-‐‑-ꟷー一]?[A-Za-zА-Яа-я\s]+$").unwrap();
let string = "Анна-Мария Кузяпкина
Ян Пупкин
Петр Фёдоров
Сергей Михайлович Прокудин-Горский
Василий Иванов
Д'Артаньян
Michael Jackson
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}