$re = '/^[A-Za-zА-Яа-я\s]{2,}[-‐‑-ꟷー一]?[A-Za-zА-Яа-я\s]+$/m';
$str = 'Анна-Мария Кузяпкина
Ян Пупкин
Петр Фёдоров
Сергей Михайлович Прокудин-Горский
Василий Иванов
Д\'Артаньян
Michael Jackson
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);