use strict;
my $str = '0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
';
my $regex = qr/\+?|0*|(972)?(.*)/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";