import Foundation
let pattern = #"\+?|0*|(972)?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)