$re = '/\+?|0*|(972)?(.*)/';
$str = '0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;