#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:\\.|[^"]|"(?:\\.|(?!test)[^"])*")*$).*"
Local $sString = "dim a as string = " test" ( test should be detected)" & @CRLF & _
"dim a as string = "abc test xyz" ( test should be detected)" & @CRLF & _
"dim test as string = "abc" ( test should not be detected)" & @CRLF & _
"dim str as string = "select id from " & test & "where place" (test should not be detected)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")