import Foundation
let pattern = #"^(?!(?:\\.|[^"]|"(?:\\.|(?!test)[^"])*")*$).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dim a as string = " test" ( test should be detected)
dim a as string = "abc test xyz" ( test should be detected)
dim test as string = "abc" ( test should not be detected)
dim str as string = "select id from " & test & "where place" (test should not be detected)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)