use strict;
my $str = 'dim a as string = " test" ( test should be detected)
dim a as string = "abc test xyz" ( test should be detected)
dim test as string = "abc" ( test should not be detected)
dim str as string = "select id from " & test & "where place" (test should not be detected)';
my $regex = qr/^(?!(?:\\.|[^"]|"(?:\\.|(?!test)[^"])*")*$).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}