$re = '/^(?!(?:\\\\.|[^"]|"(?:\\\\.|(?!test)[^"])*")*$).*/m';
$str = 'dim a as string = " test" ( test should be detected)
dim a as string = "abc test xyz" ( test should be detected)
dim test as string = "abc" ( test should not be detected)
dim str as string = "select id from " & test & "where place" (test should not be detected)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);