const regex = /^(?!(?:\\.|[^"]|"(?:\\.|(?!test)[^"])*")*$).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:\\\\.|[^"]|"(?:\\\\.|(?!test)[^"])*")*$).*', 'gm')
const str = `dim a as string = " test" ( test should be detected)
dim a as string = "abc test xyz" ( test should be detected)
dim test as string = "abc" ( test should not be detected)
dim str as string = "select id from " & test & "where place" (test should not be detected)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}