package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/(storage\/archive\/[0-9a-f-]{36}.*)`)
var str = `/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/public/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/storage/archive/not-hexadecimal-123456789abcdef01234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}