import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(storage\\/archive\\/[0-9a-f-]{36}.*)";
final String string = "/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1\n"
+ "/public/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1\n"
+ "/storage/archive/not-hexadecimal-123456789abcdef01234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}