re = /^\/(storage\/archive\/[0-9a-f-]{36}.*)/m
str = '/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/public/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/storage/archive/not-hexadecimal-123456789abcdef01234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end