const regex = /^\/(storage\/archive\/[0-9a-f-]{36}.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(storage\\\/archive\\\/[0-9a-f-]{36}.*)', 'gm')
const str = `/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/public/storage/archive/ab7572d3-c697-4cfa-9b23-71b6f9c388d1
/storage/archive/not-hexadecimal-123456789abcdef01234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}