#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{4,}|379|3[8-9]\d|[4-9]\d{2}$"
Local $sString = "370" & @CRLF & _
"378" & @CRLF & _
"379" & @CRLF & _
"379379" & @CRLF & _
"380" & @CRLF & _
"399" & @CRLF & _
"400" & @CRLF & _
"4001" & @CRLF & _
"4999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")