import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4,}|379|3[8-9]\\d|[4-9]\\d{2}$";
final String string = "370\n"
+ "378\n"
+ "379\n"
+ "379379\n"
+ "380\n"
+ "399\n"
+ "400\n"
+ "4001\n"
+ "4999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}