re = /^\d{4,}|379|3[8-9]\d|[4-9]\d{2}$/m
str = '370
378
379
379379
380
399
400
4001
4999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end