package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4,}|379|3[8-9]\d|[4-9]\d{2}$`)
var str = `370
378
379
379379
380
399
400
4001
4999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}