const regex = /^\d{4,}|379|3[8-9]\d|[4-9]\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4,}|379|3[8-9]\\d|[4-9]\\d{2}$', 'gm')
const str = `370
378
379
379379
380
399
400
4001
4999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}