package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z]+\d+`)
var str = `<p>Author</p>
<p>Availability</p>
BeautyBeauty11055981
<p><a href="APPNDX_SortValuesArticle.html#salesrank">salesrank</a></p>BooksBooks1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}