re = /[A-Za-z]+\d+/
str = '<p>Author</p>
<p>Availability</p>
BeautyBeauty11055981
<p><a href="APPNDX_SortValuesArticle.html#salesrank">salesrank</a></p>BooksBooks1000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end