// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Za-z]+\d+").unwrap();
let string = "<p>Author</p>
<p>Availability</p>
BeautyBeauty11055981
<p><a href=\"APPNDX_SortValuesArticle.html#salesrank\">salesrank</a></p>BooksBooks1000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}