$re = '/[A-Za-z]+\d+/';
$str = '<p>Author</p>
<p>Availability</p>
BeautyBeauty11055981
<p><a href="APPNDX_SortValuesArticle.html#salesrank">salesrank</a></p>BooksBooks1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);