const regex = /[A-Za-z]+\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]+\\d+', 'g')
const str = `<p>Author</p>
<p>Availability</p>
BeautyBeauty11055981
<p><a href="APPNDX_SortValuesArticle.html#salesrank">salesrank</a></p>BooksBooks1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}