#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{3}[0-9][0-9A-Z][0-9]{2}$"
Local $sString = "// Formato pré-Mercosul" & @CRLF & _
"MAR1488" & @CRLF & _
"ABC4321" & @CRLF & _
"" & @CRLF & _
"// Formato Mercosul" & @CRLF & _
"SIY5W46" & @CRLF & _
"MUS5U11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")