import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]{3}[0-9][0-9A-Z][0-9]{2}$";
final String string = "// Formato pré-Mercosul\n"
+ "MAR1488\n"
+ "ABC4321\n\n"
+ "// Formato Mercosul\n"
+ "SIY5W46\n"
+ "MUS5U11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}