re = /^[A-Z]{3}[0-9][0-9A-Z][0-9]{2}$/m
str = '// Formato pré-Mercosul
MAR1488
ABC4321
// Formato Mercosul
SIY5W46
MUS5U11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end