package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{3}[0-9][0-9A-Z][0-9]{2}$`)
var str = `// Formato pré-Mercosul
MAR1488
ABC4321
// Formato Mercosul
SIY5W46
MUS5U11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}