// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]{3}[0-9][0-9A-Z][0-9]{2}$").unwrap();
let string = "// Formato pré-Mercosul
MAR1488
ABC4321
// Formato Mercosul
SIY5W46
MUS5U11";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}