#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\bfactuur(?:nummer|\n)?.*?(?<=\s)(\d+(?:\s*-\s*\d+)?)(?=\s|$)"
Local $sString = "Factuur: 2018-4005 " & @CRLF & _
"Factuur" & @CRLF & _
"Nr. 90424571 " & @CRLF & _
" Factuurnummer: 2019-010" & @CRLF & _
"dff factuur : 281319261" & @CRLF & _
"factuurnummer: 63" & @CRLF & _
"Factuurnummer: 281329164565" & @CRLF & _
"Factuur assdg 236373" & @CRLF & _
" Factuurnummer 281319265" & @CRLF & _
"" & @CRLF & _
"Factuurnummer 0723 - 1345" & @CRLF & _
"" & @CRLF & _
"Factuur nr. 180262" & @CRLF & _
"" & @CRLF & _
"Factuurnummer : 6322232" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")