import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfactuur(?:nummer|\\n)?.*?(?<=\\s)(\\d+(?:\\s*-\\s*\\d+)?)(?=\\s|$)";
final String string = "Factuur: 2018-4005 \n"
+ "Factuur\n"
+ "Nr. 90424571 \n"
+ " Factuurnummer: 2019-010\n"
+ "dff factuur : 281319261\n"
+ "factuurnummer: 63\n"
+ "Factuurnummer: 281329164565\n"
+ "Factuur assdg 236373\n"
+ " Factuurnummer 281319265\n\n"
+ "Factuurnummer 0723 - 1345\n\n"
+ "Factuur nr. 180262\n\n"
+ "Factuurnummer : 6322232\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}