const regex = new RegExp('\\bfactuur(?:nummer|\\n)?.*?(?<=\\s)(\\d+(?:\\s*-\\s*\\d+)?)(?=\\s|$)', 'gmi')
const str = `Factuur: 2018-4005
Factuur
Nr. 90424571
Factuurnummer: 2019-010
dff factuur : 281319261
factuurnummer: 63
Factuurnummer: 281329164565
Factuur assdg 236373
Factuurnummer 281319265
Factuurnummer 0723 - 1345
Factuur nr. 180262
Factuurnummer : 6322232
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}