import re
regex = re.compile(r"\bfactuur(?:nummer|\n)?.*?(?<=\s)(\d+(?:\s*-\s*\d+)?)(?=\s|$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Factuur: 2018-4005 \n"
"Factuur\n"
"Nr. 90424571 \n"
" Factuurnummer: 2019-010\n"
"dff factuur : 281319261\n"
"factuurnummer: 63\n"
"Factuurnummer: 281329164565\n"
"Factuur assdg 236373\n"
" Factuurnummer 281319265\n\n"
"Factuurnummer 0723 - 1345\n\n"
"Factuur nr. 180262\n\n"
"Factuurnummer : 6322232\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")