#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)var days = (\[.*\])"
Local $sString = "<script class="tester">" & @CRLF & _
" /* описание */" & @CRLF & _
" var days = [" & @CRLF & _
" {"period": "2023-04-11", "Buy": 13, "Purchase": 34}, {"period": "2023-04-10", "Buy": 815, "Purchase": 107}, {"period": "2023-04-09", "Buy": 321, "Purchase": 40}, {"period": "2023-04-08", "Buy": 11, "Purchase": 18}, {"period": "2023-04-07", "Buy": 46, "Purchase": 57}, {"period": "2023-04-06", "Buy": 59, "Purchase": 13}, {"period": "2023-04-05", "Buy": 47, "Purchase": 99}" & @CRLF & _
" ];" & @CRLF & _
" </script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")