$re = '/var days = (\[.*\])/s';
$str = '<script class="tester">
/* описание */
var days = [
{"period": "2023-04-11", "Buy": 13, "Purchase": 34}, {"period": "2023-04-10", "Buy": 815, "Purchase": 107}, {"period": "2023-04-09", "Buy": 321, "Purchase": 40}, {"period": "2023-04-08", "Buy": 11, "Purchase": 18}, {"period": "2023-04-07", "Buy": 46, "Purchase": 57}, {"period": "2023-04-06", "Buy": 59, "Purchase": 13}, {"period": "2023-04-05", "Buy": 47, "Purchase": 99}
];
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);