import Foundation
let pattern = #"var days = (\[.*\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<script class="tester">
/* описание */
var days = [
{"period": "2023-04-11", "Buy": 13, "Purchase": 34}, {"period": "2023-04-10", "Buy": 815, "Purchase": 107}, {"period": "2023-04-09", "Buy": 321, "Purchase": 40}, {"period": "2023-04-08", "Buy": 11, "Purchase": 18}, {"period": "2023-04-07", "Buy": 46, "Purchase": 57}, {"period": "2023-04-06", "Buy": 59, "Purchase": 13}, {"period": "2023-04-05", "Buy": 47, "Purchase": 99}
];
</script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)