// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)var days = (\[.*\])").unwrap();
let string = "<script class=\"tester\">
/* описание */
var days = [
{\"period\": \"2023-04-11\", \"Buy\": 13, \"Purchase\": 34}, {\"period\": \"2023-04-10\", \"Buy\": 815, \"Purchase\": 107}, {\"period\": \"2023-04-09\", \"Buy\": 321, \"Purchase\": 40}, {\"period\": \"2023-04-08\", \"Buy\": 11, \"Purchase\": 18}, {\"period\": \"2023-04-07\", \"Buy\": 46, \"Purchase\": 57}, {\"period\": \"2023-04-06\", \"Buy\": 59, \"Purchase\": 13}, {\"period\": \"2023-04-05\", \"Buy\": 47, \"Purchase\": 99}
];
</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}