#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(Crude Oil).*$"
Local $sString = "Crude Oil" & @CRLF & _
"aCrude Oil" & @CRLF & _
"Crude Oila" & @CRLF & _
"aCrude Oila" & @CRLF & _
"Bakken Crude Oil:" & @CRLF & _
"a Crude Oil a" & @CRLF & _
"C rude Oil" & @CRLF & _
"a Crude Oil " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")